Slow performance & missing Clients & Departments

Incident Report for Float

Resolved

This incident has been resolved.
Posted Nov 18, 2020 - 15:14 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 05:08 EST

Investigating

We're currently investigating a report of slow performance and hidden Clients and Departments. Hold tight, your data is safe.
Posted Nov 18, 2020 - 04:34 EST
This incident affected: Float App.