Phishing attempt identified. Subject line: 'Invoice INV-0221 from Float UK'
Incident Report for Float
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 13, 2018 - 20:24 EST
Monitoring
Automated email sends have resumed, we're continuing to closely monitor activity with our email provider.
Posted 5 months ago. Dec 13, 2018 - 13:10 EST
Investigating
We're currently investigating notice of an attempted phishing attack, where emails have been sent to appear from Float requesting invoice INV-0221 be paid, with a link to collect payment.

If you receive an email with this subject line, please do not open it or click on any links. We're currently working with our email provider to get to the bottom of this.

Automated email sends, including email invites and welcome emails, have been halted until further notice.
Posted 5 months ago. Dec 12, 2018 - 20:03 EST