Issue with Reports and Search

Incident Report for Float

Resolved

This incident has been resolved. Reports, search, and integrations are back to normal operation.
Posted Oct 21, 2025 - 13:58 UTC

Monitoring

The issue was identified to be related to global internet disruptions caused by an AWS outage. We've implemented a fix to resolve the problems affecting reports and search, as well as another issue identified with integrations.

We're now monitoring the services to ensure there are no further disruptions.
Posted Oct 20, 2025 - 22:46 UTC

Investigating

We've observed an issue with services causing the reports and search to fail. We're investigating the issue and will report here as soon as identified and resolved.
Posted Oct 20, 2025 - 20:11 UTC
This incident affected: Float App.