Site not loading
Incident Report for Float
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 17, 2019 - 14:21 EDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jun 17, 2019 - 14:13 EDT
Update
We are currently investigating this issue.
Posted about 1 month ago. Jun 17, 2019 - 13:59 EDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Jun 17, 2019 - 13:52 EDT
This incident affected: Float App.