Float.com site is inaccessible for some people
Incident Report for Float
Resolved
A patch has been issued and we're monitoring.
Posted Jul 10, 2024 - 05:22 EDT
Investigating
The float.com site is inaccessible for some people, we're investigating the issue.

The float app continues to work fine and workflows for teams using the resource management tool is not affected.
Posted Jul 09, 2024 - 17:07 EDT
This incident affected: www.float.com.