Issues with our infrastructure provider

Incident Report for Float

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 18:57 UTC

Identified

There is an issue with Google Cloud our infrastructure provider that may be causing issues with; Logins with Google, slow responses in the float app, some requests may need to be retried.

We're monitoring the issue and we will update when we know more.
Posted Jul 18, 2025 - 16:04 UTC
This incident affected: Float App.