App and marketing site currently offline
Incident Report for Float
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 14, 2017 - 03:47 EDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Sep 14, 2017 - 03:36 EDT